ACH Withdrawal Issues on Web
Incident Report for BlockFi
Resolved
All systems should be back to normal operations. We appreciate your patience!
Posted Jan 13, 2022 - 16:55 UTC
Investigating
Our team is aware that clients are not able to withdrawal via ACH on the Web platform. We are actively working on a resolution; in the meantime, please be aware that your assets remain safeguarded.
Posted Jan 13, 2022 - 16:39 UTC
This incident affected: Fiat Transfers (Fiat Transfers Out).