BlockFi Credit Card Degraded Performance
Incident Report for BlockFi
Resolved
All systems should be back to normal operations. We appreciate your patience!
Posted Oct 03, 2022 - 23:10 UTC
Investigating
Our team is continuing to see some issues preventing clients from accessing and using their BlockFi credit card. We can confirm that all clients’ assets remain safeguarded, and the remainder of the BlockFi platform is fully operational. We are actively monitoring this issue and will continue to provide updates.
Posted Oct 03, 2022 - 22:01 UTC
This incident affected: Credit Card Transactions and Credit Card Dashboard.