Interest Payment Delays
Incident Report for BlockFi
Resolved
We have resolved this issue. Interest payments have been completed and are posted to all client dashboards.

We appreciate your patience while we worked toward a resolution. If you continue experiencing issues, please reach out to our Client Service team.
Posted Feb 01, 2022 - 22:11 UTC
Monitoring
The issue with January interest payments has been identified and should be resolved within one to two days. Rest assured, your interest has been accrued and we are working diligently to resolve this issue and correctly show the payment on your dashboard. We appreciate your patience while we work toward a resolution.
Posted Feb 01, 2022 - 05:33 UTC
Investigating
We are experiencing delays showing your January 2022 interest payment on your dashboards. Rest assured, your interest has been accrued and we are working diligently to resolve this issue and correctly show the payment on your dashboard. We will provide an update upon resolution.
Posted Feb 01, 2022 - 03:00 UTC
This incident affected: BlockFi Interest Account.