US Tax Form Downloads
Incident Report for BlockFi
Resolved
This incident has been resolved.
Posted Mar 17, 2022 - 12:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2022 - 15:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2022 - 13:50 UTC
Investigating
Our team is aware that some US clients are not able to access their tax forms. We are actively working on a resolution; in the meantime, please be aware that your assets remain safeguarded.
Posted Mar 16, 2022 - 13:13 UTC
This incident affected: Web Application.