Credit Score Disclosure Email
Incident Report for BlockFi
Resolved
At this time we have paused sending out further emails to clients on this matter until the formatting error can be corrected. We sincerely apologize for any confusion and are working with our BlockFi card partners to resolve this issue moving forward.
Posted Dec 29, 2021 - 19:59 UTC
Identified
Some BlockFi Credit Card clients recently received a Credit Score Disclosure email that did not contain correct formatting. Please be aware that this is a legitimate email and our teams are investigating why some clients did not receive the full message. We apologize for any confusion.
Posted Dec 29, 2021 - 16:02 UTC
This incident affected: Credit Card Dashboard.